12

Does anyone have any idea why using the link on excel opens the file as read-only mode? How can I change the behavior to open as Edit mode?

enter image description here

I checked almost all of the Document Library settings, but so far no luck.

Thank you for reading

7

The setting you want is in Excel, not in SharePoint. Excel will, by default, open documents in Protected View from potentially unsafe locations (that includes SharePoint, but doesn't include local or network drives).

In Excel 2013, the option is in File > Options > Trust Center > Trust Center Settings > Protected View. You'll want to uncheck the box that says Enable Protected View for files located in potentially unsafe locations. Depending on your network setup, the setting might be Enable Protected View for files originating from the Internet.

Excel Trust Center > Protected View

2

Try this:

Assuming you are using SharePoint 2010, go to your document library's Settings, then click Advanced Settings. Find the option for "Default open behavior for browser-enabled documents", and select "Open in the client application". Now, when a user clicks on the document name to open it, they will be able to see that they can edit it and select the "edit" option from the prompt (assuming you are using IE). Here is what that should look like:

enter image description here

  • Hello Alex, The "Open in the client application" was already the current setting. The problem I am having is that when the user clicks the link-->opens excel file-->make one change-->Save. It says that the file is read only. But if the user goes "Edit in Microsoft Excel" everything just works as expected. – MicroSumol Jan 28 '13 at 23:06
  • If you use the method that I showed above and select "edit" after clicking on the document link in the Library, I don't see how it could say the file is read only if you open it in edit mode. No need to use the dropdown and select "Edit in Microsoft Excel". – Alex Jan 28 '13 at 23:10
  • But that windows is not showing up on Excel 2010. I tried 2 different machines. – MicroSumol Jan 29 '13 at 18:27
  • It's not part of Excel. I am also on Excel 2010. I think you need to configure your Internet Explorer security settings to prompt for this. – Alex Jan 29 '13 at 18:39
  • What do you do in the cases where the user sees this modal, selects the Edit option, and the file still opens in Read-Only mode? – TylerH Mar 20 '18 at 12:53
1

Excel (and presumably other office apps) can also give the following error because OneDrive settings. No amount of changing Trust Center settings in Excel will fix it.

We opened this file read-only from the server

You need to untick the following box in the OneDrive settings. Here is more info.

enter image description here

0

I would try adding my SharePoint URL to the trusted sites and Intranet sites list in IE settings. This would remove the window Alex was referring to and allow the user to see a yellow bar at the top of the Excel window that allows them to edit the document.

0

Problem is in trusted web. Please delete URL of the site where the file is on from "Local Intranet" and "Trusted Web Site" in Internet Explorer Settings.

  • This argument suggests the opposite of TRob's answer from a year prior. Can you explain why? – TylerH Mar 20 '18 at 12:53
0

Check the box Display Intranet sites in Compatibility View in the Compatibility View Setting under Internet Explorer. This issue was only affecting one person in the entire department so I knew it wasn't something server side or widespread.

0

I was having an issue with my SharePoint 2016 on-premise farm Oct2018 CU where excel was opening as read only on the server and users were not able to edit the file. This is using Excel Version 1808 (Build 10730.20262 Click-to-Run). To resolve this we ended up running the following script on our SharePoint farm as directed by Microsoft Support:

$sec = Get-SPSecurityTokenServiceConfig
$sec.SuppressModernAuthForOfficeClients = $true
$sec.Update()

This seems to have resolved our issue.

-1

See http://support.microsoft.com/kb/2661910/en-us. User may need to have their SharePoint Server Admin make some changes in SharePoint Central Administration.

  • 3
    Please update your answer with more details. What changes need to be made etc.? If the link you provided in your answer breaks in the future, your answer will not be very useful. – Phil Greer May 13 '14 at 20:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.