I have created very simple ASP New form which looks as follow:

<asp:Content ID="Main" ContentPlaceHolderID="PlaceHolderMain" runat="server">
    <SharePoint:FormField runat="server" FieldName="Name" ControlMode="New"/>
    <SharePoint:FormField runat="server" FieldName="Title" ControlMode="New"/>
    <SharePoint:SaveButton runat="server" ControlMode="New"/>
    <SharePoint:GoBackButton runat="server" ControlMode="New"/>

Set it as a New form for Document Set content type using SPD. Also I created a new Document Library, where Document Set is one of the content types. Now, when I add new Document Set in this library, I can see my simple form.

enter image description here

After pressing the Save button, I can see new item 123 as expected.

After that I select it and try to run workflow (2013 SPD WF) on it, but it doesn't start and shows me the following error: "Something went wrong. To try again, reload the page and then start the workflow"

enter image description here

And I can see the following error in the ULS logs:

Failed to look up list item with Id 26 on list with Id 916aff44-93ff-4c93-aeca-b227e249a33a for call to StartWorkflowOnListItem() : System.ArgumentException: Value does not fall within the expected range. at Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider.StartWorkflowOnListItem(WorkflowSubscription subscription, Int32 itemId, IDictionary`2 payload).

I can see that item with id=26 exists. At least I could see it using the following link:


However, if I create new item using standard form, the same workflow starts well. Workflow is very simple and consists of the only log activity.

What I have tried:

  1. Tried to use the same custom form to create item derived from Item in a list. In such a case workflow starts without any issues. So probably, the issue related only to Document Libraries or Document Set.
  2. Tried to start 2010 SPD WF on this item. It works well. So, probably this issue is related only to new 2013 WF Manager's WF.
  3. Compare all fields of the both items (created by standard and custom forms). The only difference, which I could see is that in the working item, MetaInfo field contains additional value "docset_SkipProvision:SW|True". I tried to add it to the incorrect item, but with no results.

My ideas why it happens:

  1. I should do some additional work in my custom form when it comes to Document Set (SharePoint:SaveButton is not enough).
  2. It is a bug in platform and standard form do something behind the scenes to overcome it (but what?)

Does anybody have some ideas, why it happens and what could I try for troubleshooting? Every suggestions are very appreciated.

PS: Crosspost from Microsoft Forums.

Kind regards, Michael

2 Answers 2


I have just got an answer for this question from MSFT.

He said:

"This is a known issue that's being investigated. Document Sets generate events differently from other SharePoint content, and today these events do not flow properly for workflow."


I have experienced this issue several times on different farms. After some manipulations with the workflow using SharePoint Designer or a web browser, occasionally, it started to be impossible to open published workflow. The others workflows continued to work as expected, whereas when I tried to open the one that started to misbehave it showed the following error message “Failed to load the workflow definition for the workflow”.


I tried different things, but nothing helped. It seemed to be an issue inside SharePoint. Several days ago I found the following Hotfix: SharePoint Designer 2013 hotfix package (Spd-x-none.msp): June 11, 2013, which seemed to be the fix for this issue.

Today, I stumbled into that issue again and decided that it is a good time to test, whether this hotfix fixes this issue for me. I installed it and the issue disappeared!

Solution: So, the solution in my case was to install this hotfix for SharePoint Designer 2013.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.