I have three tier farm consisting of a WFE, App server and DB server.

I have installed Windows Azure Workflow Manager + Client on the app server without any problems and registered it with SharePoint using PowerShell. then installed the Workflow Client on the WFE, also without any errors.

I have created a simple list with one workflow set to start manually. Every time I try and run the workflow on an item in the list it fails (I get a pop-up alert in the browser saying Something went wrong. To try again, reload the page and start the workflow.").In the logs on the WFE

I see:

SharePoint Server Workflow Services aj5oh Exception System.NotSupportedException: Not supported in Windows authentication mode. at Microsoft.SharePoint.IdentityModel.SPIdentityContext.Create(SPUserToken token, Boolean isShareByLinkGuestUser) at Microsoft.SharePoint.WorkflowServices.WorkflowServiceContextExtensions.GetApplicationUserCredentials(WorkflowServicesContext context) StackTrace: at Microsoft.Office.Server.Native.dll: (sig=1f86b0bf-2440-4b16-9099-860a571153c2|2|microsoft.office.server.native.pdb, offset=131CE) at Microsoft.Office.Server.Native.dll: (offset=21C85) 14e2f59b-f71d-107d-8811-c6925cb1b356

Any ideas on what might be wrong with my configuration. I have the web application I am using setup with Kerberos authentication - which is all working fine.

Thanks for any help, Richard

  • Is this a Classic or Claims-based web application? If Classic, have you tried Claims?
    – user6024
    Jan 18, 2013 at 4:57
  • Claims based web application.
    – Richard
    Jan 20, 2013 at 21:31
  • The app is setup claims with kerberos. Is the content (db?) migrated from a 2010 farm or 2013 non claims web app? Or is it "fresh" content (new content db and new site collection)? Jun 10, 2014 at 13:09

1 Answer 1


Ensure you have run a single sync with the User Profile Application before running the workflow. WM authenticates with SP over the S2S OAuth model, passing the user ID of the person who initiated the workflow (nothing else about the user is included). The OAuth 'subsystem' (for lack of a better term) uses the UPA to lookup the user by their ID to get other information about them when the handshake occurs. If that user is not found in UPA, it will fail.

This usually only happens in a dev/test environment because most devs don't setup a UPA. Running a single full import on the UPA will usually fix it.

  • Hi @Andrew, I've run at least one UPS sync operation and user profile has been loaded, but no way, workflow displays same error. Is there any other recommandation (IIS reset, Workflow Backend Service reset, ...) ??? (Env : SP server 2013 SP1, Win Server 2012 R2)
    – KhalilG
    Aug 31, 2015 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.