I have a dev SharePoint 2010/Server 2008 VM within a test domain; I am presently unable to connect to any of the web apps on it from other machines within the same Domain using the machine name (e.g. http://sp-2010/), but I can via IP. I get "Internet Explorer cannot display the webpage".

I can access everything just fine on the SharePoint VM itself, and also from my PC, which is in a separate domain. I found this while setting up a new Windows 7 VM to run some tests on, but I've verified that it's also broken from another VM in the domain that I know used to work.

Any ideas what might be going on? I'm thinking something DNS or alternate access mapping related, but I've never touched it and don't know where to begin.

This worked in my 2013 environment. Create two Alternate Access Mappings. One for http://sharepointname.domain.com as the Intranet Zone and the other http://sharepointname as the Custom Zone. Now users get the same content from either http://sharepointname/subiste/page or http://sharepointname.domain.com/subiste/page

  • Do you have WINS configured in your environment as well as DNS? Commented Jan 17, 2013 at 22:06
  • ipconfig /all tells me I have primary/secondary WINS servers and NetBIOS over Tcpip is Enabled. All of the computers are talking to the same WINS and DNS servers.
    – lgaud
    Commented Jan 18, 2013 at 14:35

2 Answers 2


This is a DNS / NetBIOS name resolution issue.

Read this article by Rick Taylor: Name Resolution and SharePoint.

If you have both WINS and DNS configured to be used by DHCP, you have to register both the truncated server name from WINS and the full DNS host name of each server in your DNS. This means each server will have two DNS records.


It looks like somewhere along the line the IP changed and DNS still has the old one when I access from within the domain (but not from outside, where pinging the server shows it resolving as an ipv6 entry). I've fixed it by putting an entry in the hosts file, which is good enough for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.