I have a rather curious issue with some workflow tasks.

My (state machine) workflow creates a handful of tasks while running. Users interact with the tasks to move the workflow between its states. Links to the tasks are sent by email and users go to the SharePoint (2010) site by clicking on those links.

From time to time though (absolutely random it seems, because I wasn't able to find a pattern) the user gets an error page and in the logs there is always this:

System.ArgumentException: Item does not exist. It may have been deleted by another user

The task is there, as a farm administrator I can access the task. But the user can't. It seems to be a permission issue but all security settings are OK and for a similar task on another workflow the user has no issue. It basically works most of the times and sometimes it just fails.

What could be the issue? What do I look for?

  • Am experiencing the same issue while trying to create a workflow task in project server 2010 Webapplication. It worked fine for me earlier but experiencing this error message after changing the parameter name in the cs file. Am not sure what could be the issue. I also tried installing the patch file from the following weblink : support.microsoft.com/kb/2483218/en-us?sd=rss&spid=12200 And also changed the "List View Lookup Threshold" value from 8 to 16. Also tried to remove the workflow from the list, re deployed and assigned new workflow with same name to the EPT. Still having the same
    – user16332
    Apr 12, 2013 at 21:59

4 Answers 4


I've seen this too. In the end, I found the workflows weren't completing properly as there were contentions on writing to the list item (multiple steps in the wf, now consolidated to a single write operation) and the Permissions Mask wasn't getting set correctly.

You're able to see it as the Site Collection Admin though I couldn't even delete the item as an SCA. the only way to fix the task (and other) items I found, was a direct manipulation of the perm mask GUID in the DB using [proc_SecResetItemPerm].

I followed this advice Reset Item Level Permissions


I've seen this pop up in the last 48 hours myself. It seems on our side it is an issue with our older XP machines as the problem does not appear to be there for those using Win7.

Permissions checkout as again, the same user can log on to a Win7 machine and proceed just fine.


Make sure the item is checked in.

if (task.File.CheckOutType != SPFile.SPCheckOutType.None)
  task.File.CheckIn("Workflow action", SPCheckinType.OverwriteCheckIn);

I got the same error when i was deleting the specific list item progrmatically.

I observed that the item deleting event was fireing in beckend.

I solved this problem by creating two methods for disabling & enabling the events at in event receiver and created the object of evenet receiver class and called these methods before deleting the item programatically.

public class DeviationCalculateEventReceiver : SPItemEventReceiver

public void DisableHandleEventFiring()
this.EventFiringEnabled = false;

public void EnableHandleEventFiring()
this.EventFiringEnabled = true;

DeviationCalculateEventReceiver.DeviationCalculateEventReceiver itemDeletingEvent = new DeviationCalculateEventReceiver.DeviationCalculateEventReceiver();
oWeb.AllowUnsafeUpdates = true;
oWeb.AllowUnsafeUpdates = false;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.