We have a calculated column, that results in a date. It's output type is set to DateTime - Date only. When we run the search indexer, it shows up in "crawled properties" as a Text-column, and in the display (in search results) it has a string;# in front of the date-value.

Any suggestions?


Values for SPFieldCalculated field are stored in the following format:


For calculated column with DateTime type field has the following format:


When field value is rendered (GetFieldValueAsHtml and GetFieldValueAsText) its value is extracted, but it is displayed as raw value when used in search results (crawled property).

| improve this answer | |
  • Ok, I get that one, but when the column is defined as DateTime/DateOnly in the field definition, and the formula returns a date, but the search indexer returns it as "string;#DateValue", I would say there is a problem? – sarcophilus Jan 22 '13 at 20:16
  • This is a nice explanation but it doesn't solve the issue of removing the "string;#" or "datetime;#" from the search result. Is this at all possible using a calculated column? – skeletank Feb 19 '14 at 17:07
  • Thanks. I suspect the only option here would be to customize search results, I.e. to modify column formatting via xsl.. – Vadim Gremyachev Feb 19 '14 at 17:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.