So I kinda got stuck trying to fix this issue and wondering if anyone here can help. I see tons of similar issues online but every fix they suggest doesnt work or doesn't quite apply to my issue.

The main problem is the search on our SP Foundataion 2010 isnt working and gives the error: "Your search cannot be completed because of a service error. Try your search again or contact your administrator for more information"

-Looking into the logs, i see errors basically saying i need to upgrade.

-Manage Database Upgrade Status says "Database is too old and upgrade is required"

-Services on Server shows SharePoint Foundataion Search is set at starting and doesnt continue even though it shows as running on services.msc

-And the Search Server drop down on the WSS_Content database is greyed out (Expected this but still adding it)

So with all this info, I researched. Everywhere online says to use SharePoint 2010 Products Configuration Wizard to let it complete the upgrade for me. I try that and it sits at step 5 (The search service step, from what i can tell) and just stays there. I tried letting it run for a day and it didnt continue so i ultimately had to kill the process.

So my next step was to try it with PowerShell and running PSConfig. I ran that, everything showed as successful but when i check, search still doesnt work and the service still says starting.

Ultimately, i think i just need to upgrade that one search database, so i run Get-SPServiceApplication to figure out the ID, but i dont see search in that list to upgrade that specific database. All that shows is Security Token, Application Discovery, Usage and Health and BDC stuff. Should there be more in this list?

I am actually just a web programmer but since I had some experience in SP, i got put in charge of fixing this. I have no real clue on what to try now.

I found this one forum post that describes almost the exact same issue but slightly different as I dont have anything that says upgrade available. Everything seems updated but actually isnt.


Anyone that has advice would be of immense help!


Have you tried re-creating the service (i.e. Stop foundation search, detach or disable the database, re-start search and assign a new database)?

I would try that and see if it resolves your issue.

Some additional things you can attempt, is to verify if you can see the database in question with "Get-SPDatabase". If so, that at least tells you SharePoint can "See" the database. you can then try and force an upgrade:

PSConfig.exe -cmd upgrade -inplace b2b -force 

It probably wouldn't hurt to run a consistency check against the database in SQL.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.