I have a list template (.stp file) inside a module that I am deploying to a Publishing Site (SP2010) via a wsp. The elements.xml has the correct mapping to the _catalogs/lt folder.

When I deploy, my template doesn't show up in the gallery. If I browse out to the feature folder/module, my stp file is there, and I can point a browser to /_catalogs/lt/{mytemplate}.stp, and it downloads. So I believe the mapping is correct.

I've tried deploying the wsp on another site (also a Publishing site), and the templates appear in the gallery correctly.

If I try to manually upload the templates, I receive an error: The URL '_catalogs/lt/{mytemplate}.stp' is invalid. It may refer to a nonexistant file or folder, or refer to a valid file or folder that is not in the current web.

I've tried completely removing the solution and re-installing it from scratch, but no luck.

Any thoughts on how I can get the list deployed?

3 Answers 3


Just a thought; but maybe your template is corrupt, or the list it came from is from a custom list template that is not supported in the site you are uploading it to. To rule out that possibility, try this:

  1. Create a list in your site, using one of the standard definitions (Announcements, Custom List, etc.).
  2. Save that list as a template (NewTemplate.stp).
  3. Create a list based on NewTemplate.stp.

If you had no errors, then:

  1. Save NewTemplate.stp to your hard drive.
  2. Using your code, deploy NewTemplate.stp to your Publishing site.
  3. Verify that NewTemplate.stp is in the List Templates Gallery and that you can create a list from it.

If these steps work, the problem is with your original list template.

  • Unfortunately, same result...after deployment, the new template does not exist in the library. I ended up just manually creating the lists on this server (which is staging), and when I deployed the wsp to the production box, the templates installed just fine. Chalking it up to a quirk on this box. Commented Jan 30, 2013 at 15:17
  • If the List Templates Gallery is not working, try the above in another Site Collection. Your overall SharePoint install may be corrupt, you could run the SharePoint Configuration Wizard.
    – CigarDoug
    Commented Jan 17, 2014 at 13:41

Try to go to "Site actions" -> "Site settings" -> "List templates" and delete you template manually.

I suppose that there is a list created using this template on your site and when you try to redeploy this in order to have no corrupted lists SharePoint holds your previous template.

Try to find list which is using your template and delete template manually from the library.

Redeploy the solution...

Hope it helps,


  • "Site actions" -> "Site settings" -> "List Templates" doesn't show my templates after deployment, and I can't maually add them (or delete them, as I can't see them). Commented Jan 30, 2013 at 15:19

First Check the List in list template ,

Doe it display the Version and Language and Feature Id fields ?

If it is blank then this is the reason your List is not displayed in Create Menu.

Try one thing,

Add Language tag in your element.xml file of your list.

ReUpload it

Hope it will work for you

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.