1

I have created a schema.xml for a List in SharePoint2010 which includes 2 views, and for some reason i cannot select listitems in one of the views ('Configurations') while i can select them in the other ('AllItems'). The 'TabularView' property does not seem to make a difference.

Here's the <Views>-section of the schema.xml:

 <Views>
  <View BaseViewID="0" Type="HTML" TabularView="TRUE" WebPartZoneID="Main" DisplayName="Configurations" DefaultView="TRUE" MobileView="TRUE" MobileDefaultView="TRUE" SetupPath="pages\viewpage.aspx" ImageUrl="/_layouts/images/generic.png" Url="Configurations.aspx">
    <Toolbar Type="Standard" />
    <XslLink Default="TRUE">main.xsl</XslLink>
    <RowLimit Paged="TRUE">30</RowLimit>
    <ViewFields>
      <FieldRef Name="LinkTitle"></FieldRef>
      <FieldRef Name="Version"></FieldRef>
      <FieldRef Name="Type"></FieldRef>
    </ViewFields>
    <Query>
      <OrderBy>
        <FieldRef Name="ID"></FieldRef>
      </OrderBy>
    </Query>
  </View>
  <View BaseViewID="1" Type="HTML" WebPartZoneID="Main" DisplayName="$Resources:core,objectiv_schema_mwsidcamlidC24;" DefaultView="FALSE" MobileView="TRUE" MobileDefaultView="FALSE" SetupPath="pages\viewpage.aspx" ImageUrl="/_layouts/images/generic.png" Url="AllItems.aspx">
    <Toolbar Type="Standard" />
    <XslLink Default="TRUE">main.xsl</XslLink>
    <RowLimit Paged="TRUE">30</RowLimit>
    <ViewFields>
      <FieldRef Name="LinkTitle" ></FieldRef>
      <FieldRef Name="Version"></FieldRef>
      <FieldRef Name="Type" ></FieldRef>
      <FieldRef Name="scripts"></FieldRef>
    </ViewFields>
    <Query>
      <OrderBy>
        <FieldRef Name="ID"></FieldRef>
      </OrderBy>
    </Query>
  </View>
</Views>

Why can the items in the 'Configurations'-View not be selected ? What did i miss ?

Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.