I try to Migrate a SharePoint 2003 (WSS 3.0) to SharePoint 2010. I do it with the detach database method.

After I run the test-spcontentdatabase to the restored contentdatabase. I get some errors like that

Category : MissingFeature Error : True UpgradeBlocking : False Message : Database [WSS_CONTENT_SP30] has reference(s) to a missing feature: Id = [448e1394-5e76-44b4-9e1c-169b7a389a1b]. Remedy : The feature with Id 448e1394-5e76-44b4-9e1c-169b7a389a1b is referenced in the database [WSS_CONTENT_SP30], but is not installed on the current farm. The missing feature may cause up grade to fail. Please install any solution which contains the feature and restart upgrade if necessary.

Then I looked into the FEATURES Folder and copy the correspondending features (folders with the containing xml files) into the SharePoint 2010 FEATURES Folder.

After the I run the test again. But I got the same Warnings. Must I activate the copied features manually by myself? Or what did I wrong?

  • Yes it's a Foundation 2010 Server.
    – Sascha
    Commented Jan 8, 2013 at 12:08
  • I have update my response. Hope it helps now! Commented Jan 8, 2013 at 13:01

1 Answer 1


Feature with id 448e1394-5e76-44b4-9e1c-169b7a389a1b is part of Project Tracking Workspace application template for WSS 3.0 solution provided by Microsoft. It can downloaded from the Microsoft site. So, just install the ProjectTrackingWorkspace.wsp and run the upgrade again.

enter image description here

Happy SharePointing!

  • So If I have som other References like "75a0fea7-c54f-46b9-86b1-2e103a8fedba" That maps to a Feature Called TSAimage. then I must run stsadm -o installfeature -name TSAimage?
    – Sascha
    Commented Jan 8, 2013 at 12:37
  • 75a0fea7-c54f-46b9-86b1-2e103a8fedb is also provided by Microsoft in ApplicationTemplateCore.wsp and can easily be downloaded: go.microsoft.com/?LinkId=5922037. ApplicationTemplateCore.wsp is pre-req to ProjectTrackingWorkspace.wsp. Read instructions on MS site Commented Jan 8, 2013 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.