5

Hi I am getting timeout error while trying to deploy my sp solution via visual studio 2010. It happens when my a particular feature is trying to activat. The generic error message I get goes something like this:

Error occurred in deployment step 'Activate Features': A timeout has occurred while invoking commands in SharePoint host process.

I've tried increasing the timeout in the IIS console for the SharePoint website (via the Advanced settings Dialog).

How can I solve this problem?

  • If I don't have that folders.. HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0\SharePointTools Should I create it? – eflores Jul 31 '17 at 14:38
3

There is a registry value that doesn't exist by default, that can be added to change the timeout of the server, I think on development machines the default SP settings dont allow for deployment of large .WSP solutions, or could also be slower platforms.

Goto the following regustry key: HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0\SharePointTools

Add the following as a DWORD (wont be there by default)

ChannelOperationTimeout

REG_DWORD that specifies the time, in seconds, that Visual Studio waits for a SharePoint command to execute. If the command does not execute in time, a SharePointConnectionException is thrown. The default is 120 seconds.

This explains at the bottom some registry keys that can be added for debugging, which includes the one mentioned.

  • i am using server 2016 and sharepoint 2016,i cant find that registry key – Keshav Taurah Jul 31 '18 at 9:51
2

it could be related to ChannelOperationTimeout

http://msdn.microsoft.com/en-us/library/ee471440(v=vs.100).aspx

Also, don't forget to restart Visual Studio

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.