I've deployed a wsp that has 2 features. The one scoped at a web level is listed where I'd expect to see it and activates without a problem. The feature scoped at a web application can't be found anywhere. I've checked in the Templates folder and the feature's there so it appears to be deployed ok!? There doesn't seem to be any obvious issues like 'Hidden' properties configured wrongly.

What I've Tried

  • In central admin, selected the web application in app management and checked the 'Manage Features' dialog.
  • Tried searching using powershell: (Not listed in the results)

    Get-SPFeature –Limit ALL | Where-Object {$_.Scope –eq "WebApplication"}

1 Answer 1



Crack open the WSP or look at the feature folder and ensure that the feature.xml for the web application feature actually is scoped at that level.

In case you don't know, you can also rename the .wsp to .cab to open it using your favorite archive utility or Windows explorer.

If you've built the WSP yourself, make sure that you haven't added the second feature after deploying for the first time and then ran upgradesolution. Upgradesolution will not add new files to SharePoint so you will need to uninstall and reinstall the solution.


  • I already checked the cab file, it's in there as I'd expect. It's a good tip that though for those who don't know it. I have recently added the feature and did run update-spsolution exactly as you said so I suspect that's the issue - I'll uninstall and resintall and mark your answer. Thanks a LOT for your help. Jan 7, 2013 at 10:09
  • It was that, thanks again, saved me a lot of hassle there mate. Jan 7, 2013 at 10:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.