I am trying to configure Mysite to SharePoint 2013. I first tried to start User Profile Synchronization Service on my server. In that it shown an error message "No User Profile Application found. Please create a User Profile Application on the farm."

To Create User Profile Service Applcication i browse to Central Administration>>Service Applications>>Manage Service Applications.I tried to create a new User Profile Service Application i had given Name,Application Pool,Profile DB Name,Social DB Name,Sync DB Name and clicked OK. Then it run for a long time and thrown a "Request Timed Out Error".

So, I am not able to configure MySites With out User Profile Service Application Running on my server. Please help me in finding out a solution.



3 Answers 3

  • Make sure that Farm Administrator account must be a Local Administrator on the server where the User Profile Synchronization Service will be provisioned.
  • Navigate to Central Administration >> Application Management >> Manage Service Manage Application>> Click on New >> Select

enter image description here

  • Enter Name, Application Pool Name and account

enter image description here

  • Now enter the name of other databases like Social, profile etc. I will leave it by default

enter image description here

enter image description here

  • Now start the User profile service by going into Central Admin >> System Service>> Manage Services on the server enter image description here

  • Now start User Profile Synchronization Service by giving the Farm admin credentials

enter image description here

  • Make sure that ForeFront Identity Manager Services (FIM) are correctly configured and started enter image description here
  • Perform an IISReset and go get a coffee cup :)
  • Now, set up the sync connection by going to Manage Service Application > User Profile Service > Configure Synchronization Connection > Create new Connection (Note sync account in this case, dev_spadaccount must be granted the Create Child Objects (permissions) on the OU you are Syncing with. enter image description here
  • Populate the containers and select the required AD's Organization Unit to be Synced. Click on and Start the Full Import.
  • Remove the Farm account from local admins on the box running FIM

Happy SharePointing!


Having had a very similar problem, along with many other associated problems, which put my work at an altogether unacceptable, extended standstill, I decided to post the resolution I found to as many forums relating to this issue that I could.

The resolution that I found was one of two things that I did at the same time. (duh – not a smart tactic, but I was getting desperate…) I am not willing to spend the time to isolate the effects of each of these motions, so it could be one, or the other, or both.

  1. I noticed that SharePoint was moving the Farm Account Security Managed Account (The user account that Farm Account uses for credentials) from the Administrators group, to the WSS_ADMIN_WPG group. In my case Central Admin was being run on the same machine as the SharePoint Server. I run a single server developer environment. So the Farm Account needed “Log on Locally” privileges. WSS_ADMIN_WPG group did not appear to have the needed privilege, where the Administrators group did. Strangely enough though, the Administrators group is a member of the WSS_ADMIN_WPG group. So I moved the above mentioned user account back into the Administrators group.

Let me know if I’m not seeing something here.

  1. Upon examining the SecurityTokenServiceApplicationPool (the name I gave for the Security Token Service’s Application Pool), I notice that the Enable 32-bit Applications setting under the Advanced Settings had been set to True. This to me was strange as I remembered installing the 64 bit versions of everything, because the Server machine on which I was working was indeed 64 bit. So I set it to False.

After those two simple motions I did all the familiar and necessary things to be done to make sure that the system and SharePoint was running with all the latest settings and tried what I had been doing once again, and to my amazement and shock (after having tried everything on the internet several times each) it worked! I am now happily moving forward in my work! At least until the next roadblock comes along.

Weird, dumb and stupid, what were the chances? Maybe it will be worth a quick look for you.

  • Please don't add the exact same answer to this question, as you did on this one. Instead, try to specify your answer further to make it a better of this specific question. Thank You!
    – Benny Skogberg
    Oct 15, 2015 at 21:02

Please make sure, you have DB connection and permissions to create the Database in DB Server.

I'm very much sure, user profile will be created.

  • 1
    This question is pretty old and well answered. I think your answer is not needed at this point. By the way - your answer is not very helpful.
    – PhilFancy
    Feb 27, 2018 at 14:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.