I have a SharePoint 2010 Foundation site that has recently been upgraded from WSS 3.0. The upgrade was completed successfully with no glitches.

However, ever since I have upgraded the site I have got a problem relating to lookup fields on the NewForm.aspx (New list entry page) on some calendar lists that were existing on the site prior to the upgrade.

The issue is that I have two lookup fields, one for Client and another for Meeting Type / Location. When I am on the NewForm.aspx (new list item entry page) and I select an entry in one of the lookup fields the second doesn’t allow me to select anything and just gives me the top value in the lookup list without offering any other alternative selections like it should. These fields are just standard SharePoint Lookup fields and are not modified in any way, nor is the page. This problem does not happen on new lists I create (with more than one lookup field in them) in the site nor does it happen if I add extra lookup fields on the existing lists, it just leaves these two fields with issues.

I have used Internet Explorers debugging tools to see if there is an error in any of the JavaScript on the page but nothing is being reported as being a problem and I have also tried rendering the page in different standards in Internet Explorer to see if it is related to the browser but these do not many any difference. One thing that is apparent though is that the values for both lookup fields are being pulled in to the HTML of the page as I can see them when viewing the HTML source of the page when it has loaded and in the Developer Tools in Internet Explorer…

If anyone has any experience of things like this and could point me in the direction of a fix for this I would be very grateful...

EDIT: Thank you for all the suggestions so far... I did some more digging on this and also tried the suggestions and I have further information about what this may be... I have noticed that what is actually happening is that when the first field is selected the options appear as normal to be selected from. When the second fid is selected the options do in fact appear as required but they appear under the first field, for example:

  • If I select the Client field first, then I am presented with a list of options directly under the box to choose from as expected
  • If I then select Meeting Type / Location the options for this field do appear (and they are correct) but they appear underneath the Client field as though they are options for that field instead of the second (Meeting Type / Location) field.

This is the same scenario no matter which order I select the fields in. The reason I came to notice this was I moved the fields closer to each other in their order in the list and they were both on the same screen. I am thinking this is an issue with the JavaScript that renders the options for the lookup field (as there are well in excess of 19 items so SharePoint has changed the control from a standard drop down box to its concoction of a text box, a down-arrow image and a list box for the options).

Based on all the above - if anyone can shed any further light on how to look into rectifying this so the options align up as they should I would be extremely grateful...

Many thanks in advance...

  • I had somehow a similar problem this morning but it was for custom field types not custom lookup fields, I solved my problem by re-deploying that custom field which solved the issue for me, if that helps somehow :) Commented Jan 2, 2013 at 20:14
  • @TimeToShine the OP specifically states that these are OOTB field types. Commented Jan 2, 2013 at 21:31
  • @rjcup3 Yup I seen that already, but OOTB field types not working just because of migration to SharePoint foundation doesn't seems alright to me, however would like to know what "Reset to Site Definition" means, what If someone has customized there site then wouldn't resetting to site definition will override changes they made to site(I am not sure if it will or not, just wondering) Commented Jan 2, 2013 at 23:08
  • @TimeToShine the field types are clearly working fine as lookups on new lists work. If the field type was broken it would be broken everywhere. It's a form issue and "Reset to Site Definition" affects that file only, not the whole site. You are resetting the form to the default. Commented Jan 3, 2013 at 4:21
  • @TimeToShine Thanks for you help so far - I have updated the scenario with some further findings - any further help you can offer would be greatly appreciated...
    – Luke
    Commented Jan 3, 2013 at 14:36

2 Answers 2


I had had the same issue. I resolved it by applying the following KB 2687375 (should be part of April 2012 CU) then edit the NewForm.aspx (or the editForm) edit the web part on the page and set UseStandardControl on the webpart to checked as outlined in the resolution section of the KB article.

A quick test to see if your symptoms may be fixed by this is to spin up the site in FireFox and see if it works properly there. Before doing the above fix, FireFox worked as expected while IE didn't

Also, my page wasn't ghosted. and I did try deleting and recreating the aspx page with SPDesigner.

The KB Source

  • This certainly sounds like the solution. "A custom list contains more than one field that references another list that contain more than 20 items in Microsoft SharePoint Foundation 2010. In this scenario, only the first lookup field drop down lookup field will render correctly. The second (or any subsequent) lookup field will render in the location of the first dropdown." Commented Feb 20, 2013 at 16:36
  • Yes, the sad part is the full fix needs to be done on each form where the issue occurs. so for each list in which you see this problem both the edit and new forms must be modified.
    – dfminky
    Commented Feb 21, 2013 at 14:21

The upgrade was completed successfully with no glitches.

However, ever since I have upgraded the site I have got a problem...

Sounds like there was a glitch.

If there are a set number of lists being affected by this you can open the lists in SharePoint Designer. Each form for the list will be displayed. If there is a blue exclamation point icon, you can select the form and click "Reset to Site Definition" in the ribbon (or perhaps via a right-click). If the form has been modified, this will revert the file to the default form.


Here is some more information about my suggestion (drawing from credible sources):

Michael Yeager's MSDN Blog: SharePoint Terms: Ghosted, Unghosted and Reghosted (read about "Reghosting")

Jeremy Jameson's MSDN Blog: Use PowerShell to "Reset to Site Definition" in SharePoint Server 2010

Microsoft Office's Site: Reset a customized page to the site definition (SP 2007, but still relevant)

Andrew Connell's article on MSDN: Understanding and Creating Customized and Uncustomized Files in Windows SharePoint Services 3.0 (read the section "Understanding Customized vs. Uncustomized Files")

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.