My smtp server does not show sharepoint mail attempts in any of it's folders under mailroot. The account that the alert is supposed to go to has an external gmail address in it's AD entry on purpose. The recipient and the creator of the alert are the same account. The creator (and recipient) have full permissions. No Exchange, as incoming mails are not important, just smtp server enabled for outgoing. The immediate alert timer job keeps saying successful, but has a duration of 00:00, and in fact, all jobs are showing successful and 00:00 duration. I don't know about why it's 00:00. No problems in the health monitor except that it warns me that this account is also a local administative account and that it isn't wise to grant this level of permissions to a sharepoint user. Since it's a warning rather than an error, I don't think this is causing the problem.

2 Answers 2


Make sure you increase the logging options so you are capturing all the data with SNMP. A quick check is to telnet into your SMTP server and send a message directly to the GMAIL address and see if it is received. If you do this from Win7/8, 2008/2012 box you may need to install the telnet client first.

telnet SERVERNAME 25
mail from:anyaddress@yourdomain
rcpt to:yourgmail@gmailaddress notify=success,failure
to: anyname
from: anyname
subject: relay test


It may not be that visible but after the subject you hit enter, place a period ".", then enter again. this will queue the message. You should receive a 250 return message after each line if everything is good. you can double check my syntax here: http://support.microsoft.com/kb/153119

If this works then you definitely have an issue with SharePoint and you need to ramp up the ULS settings and start digging in there, as it is probably a configuration issue.

If your message is not received, then you still need to review the SMTP settings to ensure they are configured correctly. SMTP needs to be configured to send credentials to GMAIL. Also note GMAIL doesn't listen on port 25, it uses TLS on port 587 http://support.google.com/mail/bin/answer.py?hl=en&answer=13287

If all the settings are correct, next review GMAIL and make sure the domain you are sending from is whitelisted.

If this all fails you may need to start getting down into the network packets and watching the traffic to see if you request is going out, and then watching what comes back. If you are not getting anything back, then Google is blocking you and your domain/IP space may be blacklisted. However, it is also possible that the response is getting filtered out by an edge device on your network so, even thought google accepted it, it's not making it back to the server.


when you setup the alert, did it send you the notification that the alert has been setup? so the user you selected to recive alerts shouldof recived the first email stating that the alerts have been set.

If not than its deffo somthing to do with the smtp setup. I know it sounds stupid but have you made sure the user your using has the correct email?

You can look at this for reference


  • The notification makes it to the queued folder of the smtp service, which means it should be sent. But no actual alert emails make it there. The user who created the alert is the domain administrator. The receiver of the alert is also the domain admin. The domain admin has a gmail account for it's email address entry in AD. There is only one machine in this domain, which is a sharepoint server, so Sharepoint and the SMTP server and the SQL Server are all on the same machine. Commented Dec 29, 2012 at 13:55
  • ok that means there is somthing wrong with the smtp itself can you check the smtp log? post the error that is displayed into the log. for more info check this out msmvps.com/blogs/bernard/archive/2005/10/08/69742.aspx
    – Ali Jafer
    Commented Dec 29, 2012 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.