4

I'v installed SharePoint many times.

But today when install all of the pre required SharePoint not installed

setup errors unable to proceed due to the following error windows server features or roles services required by this product are note enables

error:

setup errors : unable to proceed due to the following error : windows server features or Role services required by this product are not enabled. http://go.microsoft.com/fwlink/?LinkId=106209

system information

list of Components that we Installed:

pre-requisites

dot net framework and iis

4
  • Go to Server Manager -> Roles -> make sure Web Server (IIS) and Application Server roles are there! Also, go to Features -> make sure .Net Framework 3.5.1 Features is installed Commented Dec 26, 2012 at 6:39
  • step 1 I installed them. installed but error occur. Commented Dec 26, 2012 at 6:58
  • Application Server role is also installed? What is the error when you install the roles? Commented Dec 26, 2012 at 7:21
  • @ArsalanAdamKhatri also same error Commented Dec 26, 2012 at 8:43

2 Answers 2

2

If your Server has a static IP address and its a domain controller (Installed active directory and DNS services) without any error then you should be able to make it a Web Server, don't think if application server is necessity. Anyway it seems like someone else had same problem, but if you go through comments someone solved problem by resetting environmental variables because of permissions issue.

Also check if there's any error in event viewer.

EDIT

After looking at logs, problem is that your server where you are trying to install SharePoint isn't able to connect to remote domain controller, I would suggest you to go through this link, I am pretty sure it will work :)

http://www.administrator.de/forum/windows-2008-dcom-was-unable-to-communicate-with-the-computer-pc-meinedomain-com-using-any-of-the-configured-protocols-120415.html

Hope it helps.

15
  • i have dedicated active directory server Commented Dec 26, 2012 at 9:44
  • oh I see, is there any other errors in event viewer Commented Dec 26, 2012 at 9:46
  • DCOM was unable to communicate with the computer . using any of the configured protocols. Commented Dec 26, 2012 at 9:48
  • The removal of the assignment of application Microsoft Office Excel MUI (English) 2007 from policy Default Domain Policy failed. The error was : %%2 Commented Dec 26, 2012 at 9:48
  • Driver PDF-XChange 3.0 required for printer PDF-XChange 3.0 is unknown. Contact the administrator to install the driver before you log in again. Commented Dec 26, 2012 at 9:48
1

strange. My DVD image doesnt have SQL Server and i should install that. when install it then installation is OK and .... then SharePoint and Project Server installed

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.