I'm testing this with a simple workflow:

  • Log message "Workflow has started"
  • Assign a To-do item
  • Log message "Task is completed"

Here's what we did to make it stop working:

We went and changed site column "Task Status". We deleted all the choices and entered different ones.

At that moment first message was logged, the user could open the task and click complete task button. The workflow did not continue (the second message did not log). Looking into Workflow Tasks list, we saw the fields Status, % Completed and Outcome are blank.

What we tried after realizing this was somewhat completely bad idea:

We then changed choices on site column "Task Status" back to original values and made sure we update all list columns based on this.

Now the field Status in Workflow Tasks list gets updated to "Completed" after we click "Complete Task" on task form, but % Completed and Outcome are still blank.

What have we checked

We compared content type and site column XMLs to unaffected site's XMLs and it seems the same (difference is that affected site column has a bit more attributes like ReadOnly, Version..., but they are set to default values)

Looking into SharePoint logs and Event log showed no errors or anything out of the ordinary.

I found a similar problem on internet when Assigned To field is changed to allow multiple values (the workflow cannot update it and therefor hangs), but it seems my fields are the same as out-of-the-box.

Looking for

I'm looking for some ideas of how to resolve this. Is there another log where I can look to? Have I missed something when I updated the field back?

  • Getting the same issue, you found any solution?
    – Anuja
    May 3, 2013 at 10:29
  • IIRC, when tried on fresh SharePoint installation things worked. We then narrowed the problem to the usage of external content types. Funny thing is, the ECTs did not appear to be tied to any of the content types, workflows and/or tasks. Didn't have too much time to waste, so we just created new task list to replace OOTB one.
    – Luc
    May 6, 2013 at 6:48
  • I don't have the luxury of starting on fresh sharepoint. I have to get my workflows working again. Any troubleshooting ideas? Sep 11, 2013 at 22:40
  • 1
    I've witnessed the same following an update to the site column "Task Status". I think the issue resides with the internal fields! The internal field name is TaskStatus but if you look at any created Task List prior to any change to the field you will see the field on the list has an internal name of "status". Following the update (and a flush down? < a setting when changing) the field on the list is changed to have an internal field of "Task Status" and so do subsequent task lists created. Still trying to resolve but seems to be an MS bug for sure?
    – Tezza
    Jan 17, 2014 at 13:58

1 Answer 1


I could not add a comment yet (due to my reputation), but have you tried just updating your workflow (I assume you created it through Sharepoint Designer). Try re-creating the Conditions or Steps/Actions that use those columns and re-save and see if that resolves it. I assume your workflow updates the % Complete or Outcome.

I think re-creating a site column may not quite reinstate all workflow actions that use the previous column (with same name).

Also, you can actually see the workflow's XML through Sharepoint Designer and see the reference to other fields. The workflow XML would by accessible under All Files' > Workflow (on SP2010 Designer). But I would try the first option before doing this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.