Facing a strange and frustrating issue just before Christmas :-(

Heres the scenario: I've got a custom content type, list schema , the whole works all exported from another site using the Sharepoint save site as template and import wsp file concept.

Now, the site template does not seem to export my custom actions so I've still got it in my solution to deploy manually.

The problem is that my custom actions does not publish the ribbon buttons for some reason.

Herewith the custom action definition: enter image description here

Herewith the content type definition enter image description here

All of this worked before I exported the site definition and placed it in my vs solution. I've tried many variations of the below custom action and nothing seems to be working for the content type!

Any advice?

  • 1
    I am not sure that this is the cause, but it caught my eyes immediatly: the RegistrationId in your Custom Action has a capital X in 0X0100.... instead of 0x0100... And with CAML being case sensitive...
    – Norbert
    Dec 13, 2012 at 11:31
  • Indeed. That was the answer. Another post on Stackexchange suggested it should all be uppercase though.
    – Fox
    Dec 13, 2012 at 12:24
  • Glad to hear that. I will post it as an answer too.
    – Norbert
    Dec 13, 2012 at 12:52

1 Answer 1


CAML is case sensitive. The problem is that in your Custom Action declaration, the RegistrationID is "0X0100..." and it should be "0x0100...".


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.