1

Hope someone can help. I've been 'playing' around with sharepoint and i'm trying to set it up as a kind of company intranet.

I downloaded the greenshades theme (the custom foundation one from riolinx) and its exacly what I want.

However, the quick launch doesn't seem to work, I can see the place holder using SP designer and the code to my untrained eye looks ok.

Any ideas how I can get it back?

I'm not a coder generally so this is a bit out of my comfort zone so any help appreciated. :)

1
  • What do you mean by "the quick launch doesn't seem to work" ? Is not there, links are not working, not showing all the links that were there before applying the theme? (Just wild guesses). And also please, what do you mean by "how I can get it back"? Please edit your question, include more details, so we can understand better your problem on the first read. Thanks.
    – Norbert
    Commented Dec 12, 2012 at 16:35

1 Answer 1

0

I don't know that design, but chances are the element is hidden via CSS. Using the IE Dev toolbar (press F12 to load) you can explore the page. Alternatively, you can just right click and select view source.

Search for the class ms-quickLaunch. This should list your navigation that you're missing. Confirm it's there at all.

If it isn't, then their master page did some other funky stuff. I'd have to get a closer look.

If it is there, then looking in the F12 dev toolbar, you can see what the display properties are of the class. See screen shot http://screencast.com/t/xKFAvIn37g. Select the item on the left to see it's properties on the right. If you see display:none on the right, then you can see what file is setting this property, in my example it's all corev4.css.

Sorry if this was confusing, might be too much to jam into a reply. Let me know if you need clarification.

7
  • Thanks David, I'm just popping out of the office now, but i'll investigate upon my return. Many thanks for the reply!
    – user13595
    Commented Dec 12, 2012 at 16:48
  • Just had a quick look before I leave, seems that ms-quicklaunch isn't present.
    – user13595
    Commented Dec 12, 2012 at 16:52
  • Looks like the master page is hiding it. In SharePoint Designer, you should see something like screencast.com/t/VjAuDzsu in the master page. Line numbers will differ as their master page will have different content in it. Commented Dec 12, 2012 at 17:01
  • I downloaded the same masterpage and it appears that they removed the quicklaunch all together. It'll take some customizing to jam it back in there and have the design still work, considering the HTML and CSS layouts. Commented Dec 12, 2012 at 17:05
  • Hmmm, sounds like a lost cause then. Well thank you for checking it out, much appreciated.
    – user13595
    Commented Dec 13, 2012 at 10:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.