3

I have external lists connected to a sql server database. Since the last day, some of the lists do not display data; the lists are empty, only headers are shown. (Some lists still display data, though.) But the database tables contain data. I have changed nothing about connection properties or permissions. Has anyone encountered this problem before?

  • 1
    Does SQL Server Profiler show the requests being made to the database? Does ULS show any errors? – TZHX Dec 11 '12 at 15:45
  • 1
    And does running the command that the BCS sends give results? – TZHX Dec 11 '12 at 16:11
  • sql server profiler shows requests in all cases. – AGuyCalledGerald Dec 11 '12 at 16:22
  • Try refreshing their External Content Types, go through the steps of making External Content Type and data source again... This usually happens when a column is missing from the view/table! – Arsalan Adam Khatri Dec 11 '12 at 17:49
4

I had the same issue.

My first try was to create an additional Read List operation without the Wildcard filter.

I set that as default Read List operation, and created a list based on this. That worked, but my picker in for instance External Columns no longer had my wildcard filter.

I then sat my first Read List operation (with the wildcard filter) back to beeing default Read List op. Now they both worked ok.

In the end I found out I could just use default value of % on my wildcard filter. (This is for SQL Server)

  • Thanks! Maybe some elaboration on the answer. Every read list operation is added as a separate view in the external list. On the creation of the list, the default list operation at the time is used as the default view. However when creating an External Column, the default list operation is also used to display the available filters. This poses an issue in the scenario that you have an "All view" and a "Filtered view". To have filters in the External column you need the "Filtered view" as default. To have items in the list the "All view" as default. So 1. create list 2. change the default – Mathieu Dec 6 '17 at 9:29
0

The problem was that I had a wildcard filter in the readlist operation of the external content type. Although it had "ignore filter" checked with null value and default value was "none". I am not sure why this does not work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.