I got back up of content db from a demo server and trying to attach it to a newly created web application in my personal copy of same demo server but not up to date. however I am getting this error,

WSS_Content_MyTempContent on ServerName contains user-defined schema. Databases must b e empty before they can be used. Delete all of the tables, stored procedures an d other objects or use a different database.

I tried STSADM command as well doing it through CA but no luck and same error, however If I try to give a new named Content DB to web application it does creates a new content db and gets attached to it and

If I remove just newly created Content DB from same web application using CA and then try to add it again to same web app it gives me same error I mentioned above, Strange ini !

Now if I forget what happened and try to create a new site collection using a new content db attached to web application (web application created it itself) then I get another error which is,

The site /sites/rawr could not be created. The following exception occured: Exception from HRESULT: 0x80040E14.

Also in ULS log next to this log I find this ugly log entry,

Unexpected query execution failure, error code 8162. Additional error information from SQL Server is included below. "The formal parameter "@EnableAudit" was not declared as an OUTPUT parameter, but the actual parameter passed in requested output." Query text (if available): "SET NOCOUNT ON; DECLARE @DN nvarchar(256),@LN nvarchar(128),@@DocUIVersion int,@@Level tinyint,@@S uniqueidentifier; DECLARE @ItemId int; DECLARE @@iRet int; DECLARE @ExtraItemSize int; DECLARE @Login nvarchar(255); DECLARE @Title nvarchar(255); DECLARE @Email nvarchar(255); DECLARE @Notes nvarchar(1023); DECLARE @AddedToTable bit; DECLARE @UserIdOut int; DECLARE @LoginOut nvarchar(255); DECLARE @TitleOut nvarchar(255); DECLARE @EmailOut nvarchar(255); DECLARE @NotesOut nvarchar(1023); DECLARE @DeletedOut bit; DECLARE @IsGroup bit; SET @IsGroup = 0; SET @@Level = 1; SELECT @Login = ?; SELECT @Title = ?; SELECT @Email = ?; SELECT @Notes = ?; SELECT @@S=?; BEGIN TRAN; EXEC @@iRet = proc_SecAddUser @@S, ?, ?, ?, ?, ?, @Login, @Title, @Email, @Notes, ?, ?, ?, @AddedToTable OUTPUT, @UserIdOut OUTPUT, @LoginOut OUTPUT, @TitleOut OUTPUT, @EmailOut OUTPUT, @NotesOut OUTPUT, @DeletedOut; IF @@iRet <> 0 BEGIN ROLLBACK TRAN; GOTO DONE; END ; SELECT @ItemId = @UserIdOut ; COMMIT TRAN; DONE: SELECT @@iRet, @ItemId, @AddedToTable, @LoginOut, @TitleOut, @EmailOut, @NotesOut, @DeletedOut "

I am ashamed to mention that since my server is a very very very old copy of "vdemo server" so I copied Template folder and pasted it into my local virtual server,

C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE

I copied it because original vdemo server has custom site templates that I needed on my personal server copy, now web application i already have here is working and I don't see any errors.

What I actually was trying to do is described here Moving a Web Application from One server farm to another server farm

After doing research on Google I realized that when we create a new DB or attach one it asks for Select Search Server which I did selected one we have and for some I didn't so not sure if problem is related to that or something (like I have to delete Content DB that I created myself)


With help of Arsalan Adam Khatri I figured out my servers CA got different versions so trying to download hot fixes and Service pack 2 from this link hotfixes but I am not able to find download option for hot fix 981042


After installation of WSS 3 SP 2 (SP2) it started Configuration wizard and failing with error,

Failed to initiate the upgrade sequence.

An exception of type System.Data.SQLClient.SQLException was thrown. Additional exception information Cannot find the object "SiteDeletion" because it doesnot exist or you do not have persmissions

Now I am administrator of everything..

  • Are both your servers patched the same version number/CU level? – James Love Dec 6 '12 at 19:23
  • Nice Catch James :), trying to get hot fixes and then will see if it works ! – Muhammad Raja Dec 6 '12 at 19:31
  • SharePoint 2010 helpfully tells you if it can't upgrade/attach DBs because of version numbers being way out of sync, I can't remember if SP2007 does that though. – James Love Dec 6 '12 at 19:38
  • Re your Edit: download for that hotfix: support.microsoft.com/hotfix/… – James Love Dec 6 '12 at 19:40
  • SharePoint 2007 says, "Delete all tables, Stored Procedures and ...." Loooooool – Muhammad Raja Dec 6 '12 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.