4

just customized a master page for the new SP 2013 Foundation. Deployment, activation etc. works fine (i deploy it using a .wsp built with VS2012) but every time im trying to access my sp-page with the custom master page deployed i receive a 401 unauthorized error. My log states the following:

401 UNAUTHORIZED on http://xxxxx.com/_layouts/15/start.aspx: start.aspx is anonymously accessible but could not be shown to the user. The most likely reason for this is that the master page contains a control which requires secure properties from an SPWeb (or other SharePoint object). A control which requires this type of data must be inside an AjaxDelta.

In SharePoint Designer aren't any permissions listed for the specific master page. The default master pages which are available have permissions listed. If im trying to grant permissions via sharepoint-designer nothing changes. If i look up the Gallery for master pages inside sharepoint i can see the folder which stores my master page. Unfortunately there isn't any master-page inside..

going slowly crazy here..

  • Have you recently added any custom controls / web parts? – Quinn Johns Feb 19 '13 at 22:14
  • I had the same problem recently. Could not find an answer to what was causing it. I've ended up deactivating Minimal Download Strategy feature. If you find a better answer it would be great to know it! – Denis Molodtsov Aug 16 '13 at 16:19
  • I get this problem occasionally after adding a user control... Any solution? – variable Apr 2 '14 at 7:13
  • What kind of customizations did you embed in your master page? Most probably, the error (quite explicit -that time!) message tells the truth... – Evariste Aug 17 '15 at 5:33
1

One solution is to turn off the MDS feature.

But check this link for other solution

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • 4
    Please do not post answers this dependent on a link. Add more details from the link instead and use the link as a source – Robert Lindgren Apr 2 '14 at 7:43
1

I know this is really old but I had this issue in SharePoint 2016 and have not seen my solution posted anywhere.

My issue was that I had loaded a custom master page through a solutions file.

To solve the problem, I did the following:

  1. In the Site Collection, go into Site Settings --> Master Pages under Web Designer Galleries.
  2. Find the HTML file for the Master Page you are using.
  3. From the quick menu, select Publish a Major Version

The .master file will automatically be regenerated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.