When a user searches on "http://intranet" with "All Sites", the user gets double results and the links are pointing to the same exact location/file/path.

When the user searches on "http://intranet" with "This Site: Intranet" the user just gets one set of results.

I don't understand search very well, and I checked the search settings both at the site level as well as in central administration, but I am not sure where to look to remove the double entries.

Running the following powershell script

clear-host Add-PSSnapin microsoft.sharepoint.powershell -ErrorAction SilentlyContinue $services = new-object system.collections.sortedlist $servers = (get-spfarm).servers foreach ($server in $servers) { foreach($service in $server.serviceinstances) { if ($service.status = "Online") { $s = $service.typename if ($services.contains($s)) { $serverlist = $services[$s] $servername = $server.name $services[$s] = "$serverlist - $servername" } else { $services[$s] = $server.name } } } } $services

returned: SharePoint Foundation Search SE5APP - SE5APP - SE5FE - SE5FE - SE7FE - SE7... SharePoint Server Search SE5APP - SE5APP - SE5FE - SE5FE - SE7FE - SE7...

Which makes me wonder since all of the other services only returned the server name only once.

Does anyone have any idea what it could be?

Thanks for reading.

1 Answer 1


Some places to start would be:

  • Verify that the duplicated URLS are indeed identical by copying the link from each and comparing them very carefully. If they are off by even a single character, that is enough for the Indexer to treat them as different pages
  • Go into your Search Administration settings and verify that the site itself is not being included twice in two different Content Sources. Normally SharePoint will prevent this from happening but there are ways around it. The site should be crawled as a SharePoint site and it is normally included in the "Local SharePoint Sites" content source. If that source is enabled but the site is also listed in another source, that could be the problem.
  • Check your Alternate Access Mapping in Central Administration and make sure that the internal URLs and the public URLs are defined correctly

If you do modify the Search settings, bear in mind that some changes require certain events to happen before the change will take effect. It may need an Incremental crawl, a full crawl, or you might have to reset your search index completely and then reissue the full crawl

  • I was able to find the issue with your instructions. Thank You.
    – MicroSumol
    Dec 6, 2012 at 5:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.