2

I have sharepoint 2010 with ADFS. I also created custom claims provider and set it's name as ClaimProviderName property of SPTrustedIdentityTokenIssuer for ADFS. But now I'd like the default ADFS people picker back again. But when I try to set ClaimProviderName to empty string, I'm getting error that claim provider does not exist. I tried empty string, $null, but nothing seems to work.

4

There is no way to change the claimprovider back to the original one. You'll have to remove the SPTrustedIdentityTokenIssuer and create it again with the right settings. Be sure to use the same name if you want your existing users to be able to login again.

  1. Remove your SPTrustedIdentityTokenIssuer from all web applications
  2. Delete your SPTrustedIdentityTokenIssuer
  3. Create a new SPTrustedIdentityTokenIssuer with the same settings as before (but without the settings you're trying to remove)
  4. Configure your web applications to use the SPTrustedIdentityTokenIssuer again
  • I'd just like to add that if for any reason your claims provider stops searching you may have to do this. – Snowburnt Sep 23 '14 at 17:16
  • If you were forced to use a different name for whatever reason, you can change the LoginName with Move-SPUser. (M$ told me it wasn't supported, but it worked perfectly for me for 4200 users) Then the users permissions are restored with the LoginName change. – cluckinchicken Apr 8 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.