I am creating Site Collection with Team Site Template. When I tried to create it shows me error that

The parent content type specified by content type identifier 0x0101 does not exist.

Note : After I tried to create Custom Content Type which inherits Document Content Type I got this error.

1 Answer 1


Please activate 'SharePoint Server Publishing Infrastructure' feature first, to activate the feature go to team site, site action -> site settings -> site collection feature (under Site Collection Administration group) and find 'SharePoint Server Publishing Infrastructure' activate it, please check and let me know if it worked

  • I said when I Create Team Site it is showing error. So how can I Activate Publishing Feature from Central Admin Site Creating Wizard? Nov 27, 2012 at 6:56
  • 1
    Ok got it, but one thing is confusing me at what moment you are getting the error - at the time of site creation or at the time of content type creation?
    – Diptarag
    Nov 27, 2012 at 7:14
  • Thanx Diptarag, I got the solution. I find that there was mistake in my code so that's why I was getting error. I changed the code and error was gone. Nov 27, 2012 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.