We are encountering an "Internal server error exception" when we attempt to search. The relevant error in the ULS log is:

CoreResultsWebPart::OnInit: Exception initializing: System.NullReferenceException: Object reference not set to an instance of an object. at Microsoft.Office.Server.Search.WebControls.CoreResultsWebPart.SetPropertiesOnQueryReader() at Microsoft.Office.Server.Search.WebControls.CoreResultsWebPart.OnInit(EventArgs e)

This is occurring on a fresh install of SharePoint Server 2010 Standard Edition running on a single-server farm.

We have tried:

  • ensuring that hotfix 976462 is installed (it is)
  • ensuring that the "SharePoint Server Search" and "Search Query and Site Settings Service" services are running (they are)
  • removing, then reinstalling the search application (tried, but with no luck)
  • appending ":80" to the host of portion of the search result url to see if we get a different result (we do not)
  • ensuring that the application pool is assigned correctly (it is)
  • restarting the timer service
  • restarting the search service
  • rebooting

For the sake of conversation, we'll say the server is named "pharaoh". It has the following AAMs:

  • http://pharaoh:8888, Default Zone (Central Admin)
  • http://pharaoh, Default Zone

All services and application pools are running as the farm administrator account with Domain Admin privileges (thank you in advance for not remarking on the best practices for least privilege accounts unless it is relevant to fixing this issue).

The search service is configured as follows:

  • Crawl Component 0 and Query Component 0 both online (on pharaoh)
  • Crawl Status: Online for Crawling
  • Searchable items: 82
  • Default Content Access Account: same domain admin account used for farm service
  • 1 Content Source (Local SharePoint Sites)
  • 2 Search Scopes (Shared); People (1 item) and All Sites (79 items)

Note that when we initially installed the server, we configured the service applications using Powershell per the instructions in this blog article. This seemed to run fine (except for this search issue). We have since removed the original search application and run the configuration wizard just to be sure this wasn't the issue.

We've been struggling with this for a while, so any help or insight would be much appreciated. Thanks!

  • I have this exact same problem. I have deleted the Search Service Apps and Proxies, recreated them, activated the search web parts and did an IISRESET, still getting the error. Oct 25, 2011 at 14:26

5 Answers 5


I was able to resolve this error by deleting all Search Service Applications and Proxies and creating a new Search Service Application. Hope this helps someone out there :-)

  • Note, I did try deleting and recreating the Search Service Application before, but for some unknown reason, it worked the second time. I think the first time I neglected to delete the associated proxy.
    – Anonymous
    Sep 6, 2010 at 23:30

Check your search settings in Site Collection Administration > Search Settings > Set to Do Not Use Custom Scopes


just activated the search webpart feature and did an iisreset and everything was fine



Deleting all Search Service Applications is a bit extreme. I resolved this issue by deleting the proxy, then recreating and restarting the services/server:

Remove-SPEnterpriseSearchServiceApplicationProxy -Identity [ProxyName] 
$search = Get-SPEnterpriseSearchServiceApplication [SearchID]
$searchproxy = New-SPEnterpriseSearchServiceApplicationProxy  -name [ProxyName] -Uri $search.uri.absoluteURI

I ran into the same error, but in my case I just re-ran the SharePoint Products Configuration Wizard, and it resolved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.