I have a custom timer job that loads items into a generic list. The timer job is not executing. The timer job is deployed and the feature is activated. I can see the Timer job in the Job Definitions and in the Scheduled Jobs but it never shows up in the Job History.

I have tried invoking it manually and through powershell but it just does not want to fire.

This timer job has been deployed to 2 separate farms and worked but on the new farm it is not executing. We also have other custom timer jobs on this farm which is working fine.

Any help would be appreciated.

  • 3
    have you reset the time job service? Nov 23, 2012 at 8:58
  • What do the ULS logs say at the time that they are due to run?
    – Simon Doy
    Nov 23, 2012 at 11:01
  • What happens if you start it manually in the Job Definitions section? Is the status "failed" or "success"?
    – Shihan
    Nov 23, 2012 at 11:12
  • I have cleared the cache of the timer job and restarted it. I cant find any logs in ULS regarding the timer job. When starting it in Job Definitions it does not start. It does not show in history so I cant see the Status and it does not show a Last Run value.
    – Jruie
    Nov 23, 2012 at 11:25
  • However running the Execute method from powershell. The timer job does what it should but it does not dhow up in Job Definitions as registering a run.
    – Jruie
    Nov 23, 2012 at 11:26

1 Answer 1


Could you debug the timer job locally in your dev enviornment. Remember to restart the timer service in your dev enviornment before you attach to the owstimer service from Visual Studio. If you can successfully attach and debug locally ensure the url to the site and list are the same in your UAT/PROD enviornment.

Hope this helps

  • why do we have to restart the OWSTimer service, is this a good practice?
    – variable
    Apr 25, 2014 at 6:54
  • After deploying your code (new/updated) you need to restart your timer service for new changes to take affect. Timer jobs are very stable they can b rerun and scheduled Apr 27, 2014 at 23:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.