I have a Feature with Modules that place files in the Master Page Gallery, and I recently added Visual Web Parts to the feature. Then I realized at some point the copying of files into the Gallery had stopped working, so I broke the Solution down into 2 different Features - one with Modules, and one with Visual Web Parts. Then the Gallery copying started working again.

Another strange thing is that the Gallery copying always works from Visual Studio (F5 or Deploy), but not when deploying via stsadm or Central Admin.

There are no obvious errors in the ULS log when the copying of files into the Master Page Gallery fails. It just looks like the copying isn't performed.

  • Does anyone have any ideas about this?
  • Should this have worked?
  • Why does it work from Visual Studio?
  • It should of worked, but #1 check is look at the package. Make sure everything is on the right, so many times have I banged my head on the desk and the new solution had them on the left... – Hugh Wood Nov 19 '12 at 15:05
  • @HughWood The packages are identical with respect to the manifest.xml and the feature.xml and the elements.xml - both the working and non-working package declare the placing of files in the Master Page Gallery in the same way. – MerdePoint Nov 19 '12 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.