0

A user married and her surname was changed. Her details were edited in active directory and all seems fine. DisplayName, email etc are all correct.

However, in the portal, her old name is displayed. How can this be? I checked the User Profile info in the Admin and the Prefered Name is her new name. My Site has not been activated so she can't change her own details.

Any ideas what else I should check?

Thanks

1

You need to use stsadm -o migrateuser on the server I think.

  • Thanks for the suggestion but the user id has not changed - just the surname. It looks to me that this command is to be used when the login account has changed. – paul Sep 1 '10 at 4:53
1

It mostly happens when Profile Synchronization jobs did not run properly. This job is responsible for synchronizing User Info table to profile information.

Following two links can give you detailed help

  1. http://blogs.msdn.com/b/spfargo/archive/2009/02/13/guidance-user-info-synch-in-moss-2007.aspx
  2. http://vspug.com/mirjam/2009/06/17/user-profiles-and-the-user-information-list-or-userinfo-table/
  • I think the sync is ok - the email and the preferred name are changed. It's just the name which is displayed at the top right of the page is the old name. Any one know where this comes from? – paul Sep 1 '10 at 4:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.