0

I created one site with forms based authentication and anonymous access. That is working fine. Now i want to replace the master page with the custom master page. I just copied the nightandday.master page and pasted in the same directory of the master pages. Now I changed the master page in the site settings page of the site to my custom master page. With custom master page when I signed out it is showing the sign-in page always. I am unable to show the site with anonymous access with my custom master page. I didn't approve my custom master page and I didn't publish it. Is it may be the problem? If not, How to over come this?

1

Always make sure to check in, publish, and approve your custom masterpages as they will not be visible for anonymous user as they have no permissions to see non-published content.

  • But after publishing if want to edit and save the page, sharepoint designer is not allowing to save. It is saying that another version of this file exists. What to do for this? – Mihir Nov 15 '12 at 11:54
  • @Mihir Refresh the Masterpage list or restart your SharePoint Designer to make sure it has the latest version index of your SharePoint site. – user2536 Nov 15 '12 at 11:56
  • Even though it is not working fine. Can you please give me any link or site to study about these!! – Mihir Nov 16 '12 at 5:37
0

Have you enable the anonymous access at site collection level?

http://salvatoredifaziosharepoint.blogspot.co.uk/2010/05/sharepoint-2010-abilitare-laccesso.html

http://www.topsharepoint.com/enable-anonymous-access-in-sharepoint-2010

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.