2

Initially, I thought there was a problem with a control I've made to rate a document when I found that no documents appeared to be rated.

So last night I rated documents (approved and published) using the OOTB rating control in the document library.

Since then, I've ran the two relevant social timer jobs countless amounts of times but still no rating!?

The way I'm checking the rating is through the 'View Properties' dialog (the stars are blank, the rating count is 0).

This works on test, this issue is exclusive to production.

Also, in Library Settings > Rating Settings - the 'Yes' box is checked.

1 Answer 1

2

Go to User Profile Service Application in Central Administration. Click Manage User Permissions and check if all authenticated users has rights to Social Features.

1
  • Dmitry, you've just saved me days of pain. I've read countless amounts of articles and posts on this, that's the first I've heard this suggestion. Thanks a LOT. Commented Nov 15, 2012 at 8:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.