I'm trying to retract an existing solution for my web app on MOSS 2007. I'm failing the retraction because on the solution properties page on Central Admin 3.0 while the stsadm react job is running the page says I'm denied access to the deployed files.

I already tried giving WSS_ADMIN_WPG, WSS_WPG, and the account on the server I'm using full access to the 12 folder but stsadm is still denied access.

Please let me know if I'm missing anything.

Thank you.


I ended-up forcing the 'Read-only' properties of the files for retraction to false to make it work. Although, I'm not sure how those files became 'read-only' in the first place. =\

  • what STSADM command did you used ? Nov 15, 2012 at 8:12

2 Answers 2


Is your STSADM command looks familiar to this one,

stsadm -o retractsolution -name mysolution.wsp -url http://www.mywebapplicaton.com -immediate

most people forget -immediate and then face random errors & exception.

  • Yes, I'm using immediate. I got it to work by forcing the 'Read-only' properties of the files for deleting to false. Nov 15, 2012 at 9:25

Have you tried Run as administrator?

  • Hi, yes I have. I finally got it to work with the good'ol unchecking the 'Read-only' Property of the files that weren't getting deleted. Now I wondering how those files got to that state. Nov 15, 2012 at 7:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.