So the SQL Reporting Services Service Application is running, but from Central Administration, when I click on the service, then click "System Settings", it returns an error.

Digging through correlation IDs, I found that the Web Service was returning:

HTTP Error 500.19 - Internal Server Error The requested page cannot be accessed because the related configuration data for the page is invalid.

Error Code: 0x80070003

Config Error: Cannot read configuration file

Config File: \?\C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\WebServices\Reporting\web.config

I go to the directory to check permissions on the folder, only to find it doesn't exist, though I've also confirmed in IIS that the virtual directory application is pointed there.

I've uninstalled and reinstalled the SSRS SharePoint Add-In from the SQL disc to no avail.

Additional Details Windows 2012 Datacenter, SQL 2012 Enterprise SP1, SharePoint 2013 Enterprise

  • Confirmed that everything in the SQL 2012 SP1 rssharepoint.msi installer from the "Web Server Extensions" is installed, though there is nothing in the MSI in /WebServices/ - not sure if that's supposed to be handled by an HttpModule?
    – lukiffer
    Commented Nov 13, 2012 at 19:23
  • Did you install ssrs following this guide? msdn.microsoft.com/en-us/library/jj219068.aspx if so I will be running through it this weekend.
    – Hugh Wood
    Commented Nov 16, 2012 at 11:18
  • Yeah, I tried to follow that guide except that there are a few differences. It looks like they didn't officially support SharePoint 2013 until SQL 2012 SP1 - which there's not a whole lot of documentation for. Tried to make as much sense of it as possible. I started over from scratch and am still getting the same result, although it doesn't appear specific to SSRS - it looks like there's quite a few of the WCF services failing to work properly with variants of the same error.
    – lukiffer
    Commented Nov 16, 2012 at 22:08
  • Hi lukiffer, we set this up over the weekend and we had no issues. We used the same software as you for our experiment, except perhaps each part for us was on a separate box? Was yours all on one box? Maybe it's worth checking your KB updates for issues. Maybe you have to re-setup IIS and SharePoint, after totally removing them.
    – Hugh Wood
    Commented Nov 19, 2012 at 8:47
  • 2
    @usmanshaheen - We were able to get this to work. It appears it was a problem with the SQL SP1 installer wasn't correctly updating the SharePoint component - I've posted details below as an answer.
    – lukiffer
    Commented Feb 22, 2013 at 16:43

2 Answers 2


We were able to get the RS component to successfully install by extracting the RSSharePoint.msi package from the SQL 2012 SP1 redistributable and using msiexec manually to install the package on each of the servers. The SSRS instance was unchanged, and once we had the SP1 SSRS SharePoint component installed on each of the WFEs, it worked fine - I'm assuming there's a problem with the SP1 installer.

  • Do you have any details on how you did this? We have the exact same issue with 2014
    – Snowburnt
    Commented Sep 11, 2015 at 15:13

Pull up the windows log for this event and it will tell you what was wrong with your web.config file. Fix the file and it will work.

This error is common on migrations in 2010 not seen it yet on 2013. It is usually a missing section of the web.config.

  • The web.config file doesn't exist - the parent directory Reporting under WebServices doesn't exist. As though it wasn't installed.
    – lukiffer
    Commented Nov 13, 2012 at 17:09
  • re: Migrations, this is a fresh install.
    – lukiffer
    Commented Nov 13, 2012 at 17:09
  • 1
    Throwing it at a sysadmin who may have another idea then. tweeted
    – Hugh Wood
    Commented Nov 13, 2012 at 17:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.