4

I am trying to get SharePoint's email features to work with Google Apps (alerts, emails generated by workflows, etc).

Google Apps uses port 587 for smtp and I know that the default smtp port cannot be changed in SharePoint, so I have attempted to set up a new smtp virtual server as an smtp relay. In this, I've enabled TLS, and set the default TCP port to 587.

Under Central Admin -> Operations -> Outgoing Email Settings I already set up the correct configuration - I think:

To test this I'm using a program created by Rodney Viana. This reports "Email has been sent successfully via SharePoint", but I don't receive it.

  • Outbound SMTP server - IP address of my smtp server
  • From Address - [email protected]
  • Reply-to Address - blank
  • Character Set - 65001 (Unicode UTF-8)

Any ideas?

2 Answers 2

2
+25

This seems kinda "dirty" but it works.

http://www.delphi-ts.com/blogs/lozzi/post/2011/02/09/Sending-SharePoint-emails-through-alternate-ports.aspx

Basically setting up a proxy for sending mail, pointing SharePoint to the proxy (standard port), and allowing the proxy to relay to the correct destination port.

4
  • Yeah when I read this I was thinking a smtp proxy, it's the only real way.
    – Hugh Wood
    Nov 16, 2012 at 11:21
  • This is the setup I have already tried (except that my SMTP server is running on a separate physical server). This may or may not be the problem, I can't tell. I will try installing an smtp server on the sharepoint server. Nov 16, 2012 at 21:26
  • I also notice that the blogger in your linked article failed to get TLS working. Ideally I would like TLS to be enabled. Thanks for the link anyway - I'll try following it step by step. Nov 16, 2012 at 21:26
  • The link is broken now.
    – bgmCoder
    Nov 30, 2015 at 21:15
0

I tested and you are right with the TLS issue.

HOWEVER enter codeplex proxy solution

Does what it says "SMTP Proxy for GMail and Windows Live Mail/Hotmail"

Worked perfectly for my email alerts on my test server, while testing it.

2
  • Looks nice. I'll try it. Nov 22, 2012 at 14:06
  • I just CANNOT get this to work. I get "No connection could be made because the target machine actively refused it 192.168.1.91:25" where 192.168.1.91 is my sharepoint server and where SMTPProxy is running. Jan 27, 2013 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.