1

The new User Profile properties under "Language and Region" sections, like Locale are not getting crawled although other User Profile properties and Custom Properties are also getting crawled.

0

It looks like you're almost there, just missed a detail:

  1. In Central Administration > Application Management > Manage service applications choose User Profile Service Application
  2. Under People, choose Manage User Properties
  3. Select the property you want to have indexed, e.g. Language Preferences or Content Languages and choose Edit from the drop down menu.
  4. Scroll down to the Search Settings and check the Indexed box
  5. Click OK and you're done with the first step.

Also make sure that the property you're indexing is shown to Everyone, not only Only Me. Otherwise, the crawler won't pick it up.

After another full crawl, the newly indexed properties should show up as Crawled Properties. Now the only thing you need to do is map those to Managed Properties and run the full crawl again (this is the ugly part).

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.