I try to create a workflow using SPD2013 preview on the Office 365 developer site (company.sharepoint.com). I can create and publish WF using SPD2013 without any problems, but when I start it on the item, it always cancels with the following error:

RequestorId: bb213a25-2dfd-8664-660f-83b514b328eb. Details:System.InvalidOperationException: Configuration 'Microsoft.SharePoint.ActivationProperties.RestPathPrefix' was not found and a default value was not specified. at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) in d:\bt\49341\private\source\WF\Microsoft.Activities.Hosting\Microsoft\Activities\Hosting\Runtime\Subroutine.cs:line 278 at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)"*

The Workflow is extremely easy and consists from the only log activity in the 'Stage 1' and the 'Go to End Of Workflow' in the 'Transition to stage' sections.

I haven't made any additonal actions with services (I think it is unnecessary in the Office 365 Developer site and it should work out-of-box. Is it correct or I have missed something?).

Do you have any ideas what can I do?

Thank you in advance.

PS: I have tried googling about the problem, but with no results.

PPS: Cross-post from the Microsoft Social

UPDATE1: If I create SharePoint 2010 Workflows (by selecting Platform type on start of the WF creation in SPD) it works well. When I create WF using SP2013 WF type it always cancels. Does anybody have any ideas? Any suggestions are very appreciated.

UPDATE2: Maybe I've found one possible evidence of the source of the issue. I can see in the Workflows section in SPD, that the SP2010 WF was modified by "Mikhail Pushin", but the SP2013 WFs were modified by a strange name like "i:0#.f|membership|[email protected]". enter image description here

UPDATE3: Also I can't create a new user profile. I can see all the fields for the new profile, but when I fill it in and press the 'Save and Close' button, nothing happens. I tried to do it in Internet Explorer and in Chrome. Both with no result. Maybe these issues are related to each other? Also I've tried to install SPD2013 on the another computer, but it did not help.

  • I re-tagged the question from office-365 to office-365-developer since they are quite different "products" (tried to restrict me from further commenting) Oct 25, 2012 at 3:34

2 Answers 2


Microsoft has been upgrading the O365 developer sites since SPC. Last week I went to my account and half my sites were down. Looking at the error I think the basic integration with the WAW server on your account has been screwed up.

Don't expect any support on this from Msft - they are preview trials. You can either wait and hope it gets resolved or try creating another account.


I'm 95% sure that you're running this workflow with System Account.

Recently I've had similar error - WF was working fine when triggered from any other account. Currently I can't verify that the error is the same - my platform has been updated, and now in such case workflow status turns to "Suspended". I believe that the root cause of error might be the same. Even if it's not I think that it's worth a try.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.