I have a powershell script that gathers some data and looks to upload that data to SharePoint. Im uploading the data via 2 methods, as an excel spreadsheet, and as a list item in a custom list.

When I run the script manually (as me), all works well. When I run the script through Windows Task Scheduler, the excel spreadsheet gets uploaded to the appropriate document library, and the existing list items get deleted, but the new list items do not get created.

Any thoughts what the issue could be? Im curious if its a permissions issue for the user that is scheduled to run this job, but I added their username as a site owner, AND they have the permission to upload a file\delete a list item.

Any help is appreciated, thx!

  • 1
    Have you tried to run PowerShell as that user (Shift+RightClick | Run as different user) and in that case what is the output? – Per Jakobsen Oct 23 '12 at 7:53
  • Thanks Per, this was right in line with my issue, the user executing the script has certain priveleges on the machine\Sharepoint Instance, but not completely. – ewitkows Nov 8 '12 at 21:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.