I'm facing a problem with content Types. I added a content type to thousands of lists, added items that uses that CT and now I want to remove it..

The steps I followed are theese:

  • Removed every file that uses the content type
  • Removed the content type for every document library that was using it
  • If i try to remove it from Site Settings it told me "in use"

I tried to run a script that tolds me if a List is using it and no list is using it..

How could I solve this problem? Is there any possibility to see the blocking element? I tried Sharepoint Manager 2010 but when I click on my CT it crashes.

Any suggestion? Thank you very much!

4 Answers 4


I've run into this issue myself. One or more of the things "using" it haven't been completely deleted. This answer on Stack Overflow has the solution:

  • Delete from site recycle bin.
  • Delete from Site Collection > Site Settings > Site Collection Administration > Recycle Bin.
  • Delete from End User Recycle Bin Items.
  • Delete from "Deleted From End User Recycle Bin."

That's a lot of recycling! Once complete, I was able to delete the content type.

If you can't get to the End User Recycle Bin etc, you need more permissions, you to get a farm admin (?) to do it for you.

  • 1
    As an explanation, the reason the items/lists/libraries need to be removed from the recycle bin is because SharePoint tries to support the scenario where a user restores content. If the content type no longer exists, the item won't restore as expected. By preventing the deletion of the content type, SharePoint is protecting this issue from happening.
    – shufler
    Commented Nov 30, 2015 at 19:59
  • 1
    this solution working, thanks it save lots of time. Commented Jul 11, 2017 at 15:09

you also need to make sure that there is no draft versions of a document. if it was originally from the content type you were trying to delete. you must publish draft documents

  • Thanks. it worked for one of my list. When I deleted the approval tasks items from task list, I was able to delete content type from parent list.
    – Yayati
    Commented Dec 19, 2016 at 10:39

This is old, but still relevant. I recently had this issue as well and hit all three of the issues outlined in this article (paraphrased below):

Error “The content type is in use” explained

  1. Content Exists in a Recycle Bin

    This is already covered in @Erik Madsen's answer on SO; linked by @Olly Hodgson above.

  2. Documents Not Checked-in Yet

    You have documents of your content type in your Document Library which have never been checked-in. In this case, your content type cannot be deleted, until everything is checked-in.

  3. Previous Minor (Draft) Version Exists

    You have documents in your versioning enabled Document Library which have minor (draft) version in your content type. In this case, your content type cannot be deleted, until you publish it to the next major version.

Upon resolving all three of these issues, in multiple Document Libraries where I had migrated documents to a new Content Type, I was finally able to delete the original Content Type. Quite a pain, and SharePoint offers only entirely useless error messages.


If the delete link is missing then it could also be the CT is set to read only , go to advanced settings and make it editable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.