0

We have an infopath form that we created so our staff can submit their expenses through SharePoint. This form then needs to be signed and approved by someone in upper management. Once a form is submitted, anyone in upper management can go in digitally sign the form and the resubmit to continue the workflow.

This works for everyone except two users. When these two users open the form, it opens as read only and will not submit and save their approval.

Any ideas of how to fix this?

0

There are a plethora of possibilities that could cause this. Here are a few common things you could check:

1) Ensure that those two users have the same permissions to the list as everyone else. This involves exploring how all the other users are granted access (whether it is via a SharePoint Audience, a SharePoint Group, an AD group, etc.).

2) Try manually adding the two users to the permissions on the library.

3) If there isn't any data that would be lost in doing this, you could try removing their user profiles from both the User Profile Service Application as well as the Site and Site Collection. Then run a profile sync to have their profile re-added.

4) Try this on a different Site with a different Library. Give the same permissions you gave to the main form and see if the same issue occurs.

5) Check the Event Viewer and ULS logs for any errors that occur at the time the users try to access the form.

6) Check any data sources that the form relies on to ensure the users have permissions to those.

  • We unfortunately checked all these scenarios... – Rachel Arts Oct 16 '12 at 19:28
  • The last resort (and I do mean last resort) that I would try is removing and recreating the user in AD. For many, this ultimately isn't an option. But, if it is, it will probably solve the issue. – John Chapman Oct 16 '12 at 19:30
0

May be you have two views: one is for add/edit and other is for read only (making the form read only from properties). So, check the Form Load rule where there might be the rule of if either these two users exist then switch to view to the read only mode otherwise not. Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.