Our SharePoint site was originally setup under a test name (oldname). When brought into production, I added an AAM to extend it to our production name (prodname). About 6 months ago, I added an SSL redirect in IIS which sends all http requests to https. With the addition of the SSL redirect, Outlook/SharePoint calendar syncing stopped working.

In Outlook, users are getting the error 'Task 'SharePoint' reported error (0x0004010F). 'The SharePoint List (Develop - Calendar) cannot be found If the problem continues, contact the SharePoint site admin. HTTP 404. An error occurred connecting to http://oldname.com/sites/abc/develop. A connection to http://prodname.com/sites/abc/develop, an alternate Web address for this SharePoint site, will be attempted'

Task 'SharePoint' reported error (0x80070005): 'You do not have permission to view this SharePoint List (Develop - Calendar). Contact the SharePoint site administrator. HTTP 303.'

My AAMs look like this for mapping collection: 'oldname.com'

Internal URL ------ Zone -------- Public URL for Zone

http://oldname.com Default http://oldname.com

http://prodname.com Internet http://prodname.com

https://prodname.com Custom https://prodname.com

I think I should also have the entry:

http://prodname.com Custom https://prodname.com

but according to what I've read, I can't have duplicate Internal URLs for the collection yet I also must have an entry where the Internal and Public URLs match.

Or perhaps it's not an AAM issue? Any advice would be greatly appreciated! Thanks.

2 Answers 2


You just have to set up the calendar sync with the appropriate web address using HTTPS. The error is telling you it's trying to connect to http://oldname.com/sites/abc/develop which isn't the URL you want configured. As a fallback, it is attempting to pull the calendar from http://prodname.com/sites/abc/develop, but that's hitting your HTTP Redirect in IIS.

Configure the calendar overlay using https://prodname.com/sites/abc/develop and this issue should be resolved.

Also, make sure that all user accounts requesting the calendar have proper permissions on the calendar list.

  • Thank you. I'm quite sure this is the solution and I've passed the information on to the user but I haven't heard back yet so find out if it worked.
    – user4747
    Nov 1, 2012 at 17:45

Restart your internet connection.

Disable your firewall and antivirus.

Clear your browser cache.

Flush your DNS cache.

Change your DNS servers.

Hope You Find This Useful,


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.