In visual studio 2010 I create a new empty sharepoint project. I then add a new list definition selected document library as the type of list. It generates the def and I then change the type in the list template from 10000 to 10005. When I then try to deploy the solution it reports the following error:

Feature 'myfeatureid' for list template '10000' is not installed on this farm. The operation could not be completed.

with myfeatureid being the GUID of the feature that the list definition belongs too within visual studio 2010.

Can anyone point me in the right direction as to what could be the problem. A global search for 10000 in the project has returned nothing apart from the type attribute on the listtemplate, which I have changed to 10005.


  • Why would you change the list template? Aug 20, 2010 at 22:08
  • I tried it without changing it first, changing it was my attempt to resolve the problem
    – Anonymous
    Aug 21, 2010 at 8:13

3 Answers 3


I dont think you might want to change the list template id:


Check that,

  • According to wssdevelopment.blogspot.com/2009/09/… you should assign a number greater than 10000. The point here though is that changing that number still returns an error returning a value of 10000
    – Anonymous
    Aug 21, 2010 at 8:18

It sounds like if you deployed the solution with a list template ID of x, then changed it to y, the next time you deploy, it will look for x when VS2010 retracts your solution before redeploying.

Have you tried manually retracting & deleting the solution from your environment with PowerShell, then re-trying a deployment?


Are you sure that your list template is attached to at least one feature and that feature is part of the package of your solution ?

Did you try to deploy your solution on another site collection ? I was so used to the 2007 way of packaging / deploying that I made some mistakes in my first VS 2010 SharePoint solutions where a bunch of actions are not semi automated...

You can also try to package your solution then deploy it manually (uninstall solution, remove solution, add solution, deploy solution through stsadm) to see if it's a solution issue or something related to the way the project has been set up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.