We recently upgraded from Windows Server 2003 to 2008 R2. During our upgrade we accidentally removed IIS and reinstalled it again and now the site can only be accessed locally and if we try to access it externally we have to use the IP address.

So far we have tried the following:

  • Ping the server name my notebook: it is accessible.
  • Ping the server name on the box itself: it is also accessible.
  • Ping the server using the IP Address locally on the box and on my notebook : it is still accessible.

The other thing is that when we use IP address, the site returns repeated logon screens until you click on cancel.

Here is the error we get when try to access it on my notebook.

Not Authorized: HTTP Error 401. The requested resource requires user authentication.

Many thanks, Sepaka

2 Answers 2


You might want to look at the authentication settings in IIS7, select the IIS site which hosts your main web application, from the IIS menu select 'Authentication' ensure Windows Authentication is set and then when that is highlighted select 'Advanced' and see if you've got Negotiate above NTLM, if in doubt just use NTLM and remove Negotiate.

  • Thank you very much Pigeon. I switched to NTLM only and it worked.
    – Sepaka
    Oct 9, 2012 at 7:25

I think you might be missing some settings in iis manager!

can you check out the link below to see that its mapping is configured properly!


this is for 2007 but 2010 has the same priciples ;)

hope it helps :)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.