13

I have a masterpage (copy of v4.master) and I added a link to a custom css. when I create a new site it does not pick up the correct master page. How do I fix this? thanks

  • In what edition you have created this master page? I mean 2007 or 2010? – Zakir HC Oct 8 '12 at 12:58
  • 1
    Is this for publishing sites? We only use Team sites, how do I manage ensuring that all subsites utilize our custom master page? – user14047 Jan 10 '13 at 17:34
14

You can turn on the Publishing feature for the Root site and in the Site Action -> Site Settings -> Master Pages you will see a screen like below:

enter image description here

Here you can specify to inherit the root-site master page for sub-sites!

Also, if its just a CSS that you have used - at the bottom you can see an option to Specify a CSS to be used by this publishing site and its sub-sites!

Read answer from David-Andrew-Smith on this URL for detailed info

Hope this helps

  • Thanks the odd thing is my sub site does not give me the option to pick "Master page" under the Look and Feel section. I only have Title,description,and icon -- Tree view -- Site theme --Navigation. – Jjp Oct 8 '12 at 13:34
  • Never mind I see I was to check the box at the bottom. All works great. Thanks. – Jjp Oct 8 '12 at 13:45
  • As Arsalan said, you need to activate the publishing feature for the link to the master page to show. – Sam Sussman Oct 8 '12 at 13:48
  • Jjp, if the answer was helpful please mark that as Answer for the question! Thanks. – Arsalan Adam Khatri Oct 13 '12 at 13:42
  • The comment about checkbox is what I need. Thanks. – Mark L Jun 25 '14 at 7:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.