4

I have my user profile synchronization setup and working but I have noticed that disabled users who no longer work for my company are showing up in the sync. I would like to update the sync so that it only pulls in active users.

12

I found my solution from this blog.

  1. Go to your Central Admin website
  2. Go to "Application Management"
  3. Go to "Service Applications -> Manage Service Applications"
  4. Click on "User Profile Service Application"
  5. Click on "Synchronization -> Configure Synchronization Connections"
  6. Click on your connection and select "Edit Connection Filters" from the menu
  7. Add a new Exclusion Filter for Users and select "userAccountControl" as the attribute, "Bit on equals" as the operator, and "2" as the filter. Make sure also that you correctly have AND and OR selected if there are any other exclusion filters already there.

    userAccountControl Bit on Equals 2

  8. Click "OK"

The next time that it syncs your disabled accounts should be gone.

  • 1
    I did it but after a Full-Synch I can still see disabled users. (from "Profiles Missing from Import" view). (SP2013) – Nk SP Nov 10 '14 at 15:44
  • Make sure you select "bit on equals", not just "equals". – Anthony Kasses Aug 6 '16 at 5:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.