I have a calendar and when an event is created the users usually choose to create a meeting workspace. This all works fine, however, the creation of the workspace subsite also creates a link in the Top Navigation Bar dropdown, which I DO NOT want. I know I can delete it in Site Settings but I don't really want to have to delete meeting workspace links on a daily basis.

Is there a way to create the workspace without a shortcut to it appearing in the Top Navigation Bar dropdown? A solution that is code free would be pretty great! (I am using SP Server 2010)

  • Anyone have any ideas????
    – Tudor
    Commented Sep 27, 2012 at 15:39

2 Answers 2


That is because in the Meeting Workspace sitetemplate (onet.xml) there is an entry for a NavBarLink. You could make a webtemplate of your Meeting workspace and customize it anyway you like it, ofcourse this is not code-free but gives you total control of your meeting workspaces.

  • Do you know any good resources that go into detail for how to create the web template using code? Do I do this in SharePoint designer?
    – Tudor
    Commented Sep 28, 2012 at 15:28
  • I always find it easier to copy paste the sitetemplates from the default Sharepoint defintions and then customize them to my needs in Visual Studio. You could also do your modifications of the site in Sharepoint and then save it as a template (check site settings). Next time when you create a meeting workspace you should be able to select the customized template.
    – Martin
    Commented Oct 2, 2012 at 7:08

Can't seem to find a solution but I did find a work around. I created a sub site of the subsite of my SharePoint site :p and I created the Event Calendar as part of that subsite. Since I only have a 2 tier drop down menu system the workspaces that are created on the third tier will not be displayed OR I can just uncheck 'Show Subsites' under Site Settings -> Navigation and I get the same effect, no shortcuts in the dropdowns for the workspaces created as part of the calendar events.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.