I have a site column set as "Multiple lines of text" and, under "Specify the type of text to allow:", "Enhanced rich text" is selected. When In the "Edit Properties" dialog, placing my cursor in the field for that column's value isn't making the Editing Tools tab appear on the ribbon.

After some testing, I can only get rich text fields to work on lists... Do rich text fields only only have full functionality on lists?

1 Answer 1


Whether a known bug, as some sources claim, or a missing capability, SharePoint 2010 doesn't allow anything more than plain text to be used in a column on a library or picture library. Regardless, there is a workaround. An IT tech on our SharePoint team found the article "Add Multiline Rich Text/Enhanced Rich Text column to document library or picture library". Taking the steps described in the article, I was able to create a library with fully functioning multiline enhanced rich text columns. I'm reproducing the article here because the blog hasn't had a new post since July 22, 2010 and I'm concerned it won't persist.

  1. Go to Site Settings>Galleries>Site columns.
  2. Create a new site column (or columns) with the information type set as "Multiple lines of text" and set the column to allow rich or enhanced rich text. Create New Site Column
  3. Go to Site Settings>Galleries>Site content types.
  4. Create a new custom content type using a document content type as parent. Create a new Content Type
  5. Edit your new content type and add your new site column. Add New Site Column to Content Type
  6. Go to All Site Content and create a new document library. (This library will not have the desired functionality) Create a New Document Library
  7. Go to your new library's Settings>General Settings>Advanced Settings and set "Allow management of content types?" to yes.
  8. When you return to your list's settings, the Content Types section will be visible. Select "Add from existing site content types"
  9. Select your new content type from the left list, click "Add >", then click OK. (Optional: When you return to the settings, you can remove the Document content type from your library if you don't want it to be on descendant libraries by default. Add a new content type
  10. Now, from your new library's Settings, in the Permissions and Management section, select "Save the library as template".
    Save as a template
  11. Return to to All Site Content and create a new library using your new template. Create a new library

The library created from your new template will have your new content type and its new custom rich text column(s). The fields will be fully functional in this library.

Rich text columns not added to the new content type and then the new template will not be fully functional even if the library was created from the new template, nor will adding another rich text field to the content type update the new template or any descendant libraries.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.