I had a custom field deployed in one of server and now am trying it on my VPC which is exact copy of Server, however I added/deployed solution, checked GAC, dll was there, looked at controltemplate folder it had control in it.

I got site template from server to my VPC, now when I try to add a new item, I can see label and space in front of label but no text field so that I can enter value. any ideas what am missing ?

I looked at features but couldn't find any related to this custom field to be activated


I solved the problem, my control template was in 12/templates/control templates/sub-folder moving it to control template solved the issue but problem is it has been deployed through ".wsp" solution file so why control template wasn't picking it up from sub folder, permissions for the folder wasn't the issue.

1 Answer 1


glad you solved the problem, by documentation sharepoint should look for sub-directories but there is some bugs related to it, similar problem on stack overflow


  • link takes me to place where they are trying to upload custom template from a different location programmatically but since my template is for a custom field, I can't load it myself in the code, it had to done by default Sep 20, 2012 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.