I've downloaded some of the sample apps for SharePoint 2013. After changing the site URL, I tried deploying the app to my SharePoint 2013 preview account.

After waiting a while (first uninstalling, then installing) the following error is thrown:

"The requested name is valid, but no data of the requested type was found".

In the meantime, something did happen. The app was actually deployed in SharePoint. When I now try to open the app, it redirects to localhost which isn't started yet, with a page not found as a result (seems fair). So I manually start the local IISExpress instance; return to the app in SharePoint and try again: works.

So all the bits seem to be deployed ok, but somehow the debug process doesn't work quite right. It could have something to do with our proxy server, as I had some other problems with that too. But I tried setting it explicitely (as opposed to a config script), didn't help. Also; the requests are send out fine when I check with Fiddler. But one set of requests does seem to be recurrent a few times before failing.

Any ideas?

1 Answer 1


it simply asks the Operating System to perform all Name Resolution, and this error is being returned by the Operating System to the software. Therefore, if you're entering the computer's name (its hostname or fully qualified domain name), try using the IP address instead. This should resolve the issue in most cases.

I guess there is some problem with name resolution.

Source of Information

  • ? If that was the case, it shouldn't deploy to SharePoint alltogether right? Which is quite obviously does.
    – Jasper
    Sep 18, 2012 at 13:42
  • SharePoint is quiet unpredictable, there's so many things going on for one single event that you can't really assume what's actually went wrong, but I just assumed it could be name resolution problem or network related problem by looking at error :)
    – Change
    Sep 18, 2012 at 13:47
  • Yes that's what Google says. But it doesn't get me closer to a solution, and to get to a solution you first have to get to the origin of the fault. But thanks nonetheless.
    – Jasper
    Sep 20, 2012 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.