I have a Content Editor Web Part, pointing to an html file at the web app's root (Content Link = "/Style Library/MyCollaborationWebParts/MyCollaborationLinks.html"). The content showed by the CEWP however is an old version of the html file.

To be clear, the site containing the CEWP has been created by backup and restore, or some other such process. It originally had no Content Link value; yet it showed an old version of the html file. I filled it in recently, and the content showed did not change at all.

I have cleared my browser's cache.

I have clicked on the "preview" link and confirmed that I could see the html file

It might be of interest that the CEWP is sitting inside another CEWP

  • are you saying that you have updated the html file but its not updating on the cewp? I know it might sound stupid but have you tried ctrl + F5 ?
    – Ali Jafer
    Commented Sep 17, 2012 at 8:56
  • well, not in that order i suppose... it had the content of the old version of the html in the CEWP, and i updated the CEWP with the url of the html... ill update with further details.
    – Nacht
    Commented Sep 17, 2012 at 8:59
  • yes i've tried ctrl-f5
    – Nacht
    Commented Sep 17, 2012 at 9:43

2 Answers 2


ok how are you linking up the url of the html file to the cewp? is it in the document lirary? if not you should put it in there. then get the url from that and put that as the link in cewp. You can then update the html file in the document library and it will update the cewp every time.

  • updated... sorry im not being very clear :\
    – Nacht
    Commented Sep 17, 2012 at 22:30

Instead of actually figuring out why my CEWP wasn't working, I simply replaced it with a Page Viewer Web Part, which was far more suited for the job. Unfortunately that meant deleting 42 CEWPs and replacing them with PVWPs, but it was worth it.

I would still like to know why the CEWP provides this functionality if it does not fully work and if the PVWP is more appropriate for the task.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.