So I have the web application for my intranet at the URL "http://sharepoint/" however, I don't want people to be on the root of the web application as its not the actual home page.

I created a separate page which is to serve as the home page of the site and its URL is "http://sharepoint/home/". Now is there a way that I can make it so when a user goes to "http://sharepoint/", it will automatically redirect him to "http://sharepoint/home/"??? How can I achieve this?

Thanks for the help!

3 Answers 3


There are many options(JavaScript, IIS settings..etc) to do this

Hope this helps to explore all the options : http://www.toddklindt.com/blog/Lists/Posts/Post.aspx?ID=48

  • Thanks! I actually came across that too but maybe you can help me with something...I am trying the JavaScript method and it works but its not instant. It still goes to the original site and then redirects even if I set the time in the JS to 0. Any idea how I can make it a bit faster? This way the users get a short glimpse of the other site...
    – Tudor
    Sep 14, 2012 at 17:32
  • window.onload = function(event) { event.stopPropagation(true); window.location.href="google.com"; };
    – Vamsi
    Sep 17, 2012 at 15:32
  • I tried your code pasted in a content editor in <script> tags but it wasn't doing anything...am I doing something wrong?
    – Tudor
    Sep 17, 2012 at 23:05
  • If you are using SharePoint 2010 , then the script tags are encoded. you have to use an external file and link it in the properties of the Content Editor. Try using alert('Test'); statements to check whether the script is getting executed or not.
    – Vamsi
    Sep 18, 2012 at 13:52
  • Doesn't seem to be working for me, I have this code in an external file: window.onload = function(event) { event.stopPropagation(true); window.location.href="sharepoint/home/";; }; and its not doing anything, not going to that URL. However, this works: <meta http-equiv="refresh" content="0;url=sharepoint/home"> but it takes the user to the old page for 1 sec then redirects.
    – Tudor
    Sep 18, 2012 at 16:54

I've managed to do this by editing the web.config in the virtual directory of SharePoint. I added this section to the authentication part:

<authentication mode="Forms">
      <forms loginUrl="/sites/intranet" />

After that, the root redirected to my site.


Have you tried setting the welcome page from sharepoint ?

It should work as well. Go to Site Settings - Welcome Page and set your welcome page URL.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.